Page 1 of 1

Packager of 5.6.161.0 is definetly broken!!!!

Posted: Thu Apr 11, 2019 7:21 am
by info@t4dt.com
To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: 5.6.161.0
32 or 64 bit version of product: 64bit
Operating system: Windows 10
32 or 64 bit OS: 64bit

*** Please add details and screenshots as needed below. ***

I can confirm, that the packager is bugged. DO NOT UPDATE UR STUDIO TO 5.6.161.0 :evil:
I seems, that special characters, like & or - are not escaped well.
After the update all my projects stops, because of the broken packager

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Thu Apr 11, 2019 7:44 am
by info@t4dt.com
If i pack it to consoleapplication, it doesnt bootstrap. As window app it shows:

Code: Select all

Line 11972: In Zeile:11971 Zeichen:60
+ ...       $value = $CommandLine.Substring($index + 1, $closeIndex – ($i ...
+                                                                  ~
")" fehlt in einem Methodenaufruf.

In Zeile:11971 Zeichen:61
+ ... ue = $CommandLine.Substring($index + 1, $closeIndex – ($index + 1))
+                                                         ~~~~~~~~~~~~~~~~~
Unerwartetes Token "– ($index + 1))
				[void]$Arguments.Add($value)
				$index = $closeIndex
				
				#Find First Quote 
				$index = $CommandLine.IndexOf('"', $index + 1)
			}
		}..
In the ps1 it is like:

Code: Select all

$value = $CommandLine.Substring($index + 1, $closeIndex – ($index + 1))
			[void]$Arguments.Add($value)

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Thu Apr 11, 2019 8:11 am
by Olga_B
Hello,

what encoding are you using for your script?
Please check update note
UPD: Distinguish UTF-8-BOM and UTF-8 (No BOM) in the encoding menu.
Try to change the encoding to UTF-8-BOM

When you package script are you using the "Resolve and include external scripts" option?

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Thu Apr 11, 2019 9:06 am
by info@t4dt.com
Which script? All my files are created inside powershell studio. I never saw the option to change the encoding of scripts-files in studio. And no i don't use "Resolve and include external scripts". I mark them as shared.

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Thu Apr 11, 2019 9:09 am
by Alexander Riedel
Please indicate the encoding of any script that displays that problem. The current encoding of a script file is displayed on the status bar. Clicking on it shows a menu to change the encoding of the current file.

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Thu Apr 11, 2019 12:08 pm
by Alexander Riedel
After further looking into this, the character that is flagged here is probably a hyphen not a minus sign as you want it to be.
This can happen quite frequently when you copy and paste code from a website.
The screenshot below illustrates the same error message when using an en-dash character instead of a minus sign in a script.
Em dash.png
Em dash.png (46.58 KiB) Viewed 1543 times
I would suggest to specifically erase the hyphen and type a minus character. This should resolve the issue. Unless you have any additional information, I am thinking that this has nothing to do with the packager.

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Fri Apr 12, 2019 2:54 am
by info@t4dt.com
Ok, this works. Found one other problems with different paranthesis handling in this version (i could fix this by myself). I am wondering, because this part of the programm is more than four years old and did work all time along. And it does in the studio version 5.6.160.0.
All scripts are encoded in utf8-bom.
Thank you for the good advise!

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Fri Apr 12, 2019 3:05 am
by info@t4dt.com
But one other thing remains: All unicode-signs like ä,ö,ü, ß are wrong in the gui after packaging

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Mon Apr 15, 2019 10:11 am
by davidc
Until the issue is resolved, you can set file's encoding to Unicode (UTF16 LE) as a work-around.

Re: Packager of 5.6.161.0 is definetly broken!!!!

Posted: Fri Apr 19, 2019 6:47 am
by davidc
The v5.6.162 service build is now available and should resolve this issue.