Page 1 of 1

Interface issue in PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 11:49 am
by bgleason
To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio 2019 v5.6.159
32 or 64 bit version of product: 64bit
Operating system: Windows 10 1803 (10.0.15063.1563)
32 or 64 bit OS: 64bit

If you enable High DPI compatibility for Powershell Studio 2019:
Right click on PSS shortcut, got the compatibility tab, enable the setting "Override high DPI scaling behavior.", set that option to "System (Enhanced)" and OK out. Now you will need to relaunch PSS for that setting to take affect.

On High DPI monitors, some of the Viewed controls are displayed twice at different scales, almost like one is for SD monitors and the second is for High DPI monitors.. the duplicated items are the "Object Browser", "Project" and "Snippets". You will see in the attached screenshot:
Screenshot_1.png
Screenshot_1.png (263.86 KiB) Viewed 1974 times
Thanks,

Brian


DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM

Re: Running PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 11:59 am
by bgleason
Also, to add a note...

It has started happening sometime between the version I posted here: viewtopic.php?f=21&t=12245
and the version I am referencing in this support request...

So Sometime between PowerShell Studio 2017 v5.4.145 and PowerShell Studio 2019 v5.6.159

If I recall correctly, I started seeing it with the Powershell Studio 2018 release... Sorry for being late to the game, I have just been out of PSS for a bit...

Re: Running PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 12:25 pm
by Olga_B
Hello Brian,
What is your monitor resolution and scaling?

Re: Interface issue in PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 12:35 pm
by bgleason
Thanks for the quick response...

I have three monitors on my build, all different resolutions and an additional note...

Display 1 (1920x1080) Scaled at 125% (HP 840 G4 (laptop) w/ High DPI display)
Display 2 (3840x2160) Scaled at 150% (HP Z27s)
Display 3 (1920x1080) Scaled at 100% (HP EliteDisplay E232)

In a single session, re. run Open PSS without closing, when I open PSS and have it on display one, it shows the issue. Dragging the window to display two, shows the issue. If I drag it to display three, the issue goes away. Again without having to close PSS.

Thanks,

Brian

Re: Interface issue in PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 1:09 pm
by bgleason
Just for kicks and grins, I changed the scaling on my primary from 125% to 100% and the issue did not present itself...

From this on Display 1 I reduced my Resolution from 1920x1080 @125% to 1600x900 @100% which gives me roughly the same resolution...
and Display 2 from 3840x2160 @150% to 2560x1440 @100%.. This has worked around the, for lack of a better description, control ghosting in the PSS interface.

Sooo looks like, with High DPI compat enabled via "System (Enhanced)" Method, when there is scaling on the monitor the interface is running on, certain Panels are ghosted in the scaled and unscaled resolution simultaneously... I would like to run at full resolution regardless of scaling, as I dont scale/adjust everything... Not sure what else this may impact on my other toolsets...

Thanks,

Brian

Re: Interface issue in PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 3:33 pm
by davidc
Thanks for the information Brian. This looks like a bug with the UI library. I will try to contact the vendor in order to resolve the issue.

Re: Interface issue in PSS with High DPI Scaling Compat Enabled

Posted: Tue Feb 26, 2019 3:43 pm
by bgleason
Anytime... Thanks...

Brian

Re: Interface issue in PSS with High DPI Scaling Compat Enabled

Posted: Thu Feb 28, 2019 12:55 pm
by davidc
The vendor got back to me. When you set the application to System (Enhanced) it uses GDI Scaling, which is not compatible with applications that use mixed rendering (DirectX and GDI). Unfortunately, this is an issue with Windows can't be resolved on our end. Therefore, I don't recommend using this setting with PowerShell Studio.