STA Mode lost when debugging

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
VereinigungHH
Posts: 6
Joined: Wed Dec 17, 2014 8:33 am

STA Mode lost when debugging

Post by VereinigungHH » Fri Jan 18, 2019 8:08 am

Product: PowerShell Studio 2019 (64 Bit)
Build: v5.6.157
OS: Windows 7 Professional (64 Bit)
Build: v6.1.7601.65536

I have a GUI Application with FileOpenDialog etc. STA Mode ist enabled in the Home/Platform Ribbon.

Just updated to the newest Version. When I run the Application from the IDE via Home/Run the GUI starts.
When I start via Home/Debug this Error appears:

Exception setting "AutoCompleteMode": "Für den aktuellen Thread muss der STA-Modus (Single Thread Apartment) festgelegt werden, bevor OLE-Aufrufe ausgeführt werden können. Stellen Sie sicher, dass die Hauptfunktion mit STAThreadAttribute gekennzeichnet ist."

It seems to me, that, when Debugging, the STA-Mode setting is lost.

Any Ideas?

Kind regards, Goetz

User avatar
davidc
Posts: 5801
Joined: Thu Aug 18, 2011 4:56 am

Re: STA Mode lost when debugging

Post by davidc » Fri Jan 18, 2019 9:44 am

We were able recreate the issue and it will be resolved in the next service release.
David
SAPIEN Technologies, Inc.