Could not find a part of the path....

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
IanUoY
Posts: 66
Joined: Wed Jul 31, 2013 2:09 am

Could not find a part of the path....

Post by IanUoY » Thu Nov 08, 2018 7:15 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: 2018 5.5.155
32 or 64 bit version of product: Assume 64-bit
Operating system: Windows 10
32 or 64 bit OS: 64

Have not used Powershell Studio for a while. Have accessed a project a wish to work on further. Previously I was working using a different version, got an indication of having to save to create a backup before converting to newer format.

However in my output window, I'm getting the message below repeated every minute or so:

Recovery Error: Could not find a part of the path '\\"path - this is correct"\Application Data\SAPIEN\PowerShell Studio 2018\Recovery\14236'.

Could you advise how to resolve this please?

Many thanks

DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM

User avatar
Olga_B
Site Admin
Posts: 68
Joined: Mon May 15, 2017 9:06 am

Re: Could not find a part of the path....

Post by Olga_B » Thu Nov 08, 2018 9:25 am

Could you provide more information about what version of product did you use before.
Also could you zip and load up your project, so we can attempt to recreate the issue to:

https://www.sapien.com/support/upload

User avatar
davidc
Posts: 5474
Joined: Thu Aug 18, 2011 4:56 am

Re: Could not find a part of the path....

Post by davidc » Fri Nov 09, 2018 8:03 am

This is not linked to the project but to PowerShell Studio’s file recovery feature which saves the edited files in case the application is unexpectedly terminated. This error appears when PowerShell Studio fails to create the recovery folder.

Do you have any restrictions on the Application Data folder?

Note: You can disable the recovery feature in Options->Backup->Enable file recovery:
Option - Enable File Recovery.png
Option - Enable File Recovery.png (21.26 KiB) Viewed 419 times
David
SAPIEN Technologies, Inc.

User avatar
IanUoY
Posts: 66
Joined: Wed Jul 31, 2013 2:09 am

Re: Could not find a part of the path....

Post by IanUoY » Mon Nov 12, 2018 5:16 am

I removed Powershell Studio completely in the end, however, on trying to re-install I now get:

Warning 4154: Document explorer prerequisite was not correctly installed....continue? etc.

If I do continue moves to MSCHart, ScriptMerge, sure you get the picture.

Is there a separate prerequisites installer?

Regards

Ian

User avatar
davidc
Posts: 5474
Joined: Thu Aug 18, 2011 4:56 am

Re: Could not find a part of the path....

Post by davidc » Tue Nov 13, 2018 8:05 am

Please check if the prerequisites are already installed. Uninstalling PowerShell Studio will not remove the prerequisites from the machine because they have separate installer entries in Windows.
David
SAPIEN Technologies, Inc.

User avatar
IanUoY
Posts: 66
Joined: Wed Jul 31, 2013 2:09 am

Re: Could not find a part of the path....

Post by IanUoY » Tue Nov 13, 2018 8:14 am

The ones I've mentioned do not appear to be installed. Is there a separate Sapien installer for this? Or should Powershell Studio install if not found?

Ian

User avatar
davidc
Posts: 5474
Joined: Thu Aug 18, 2011 4:56 am

Re: Could not find a part of the path....

Post by davidc » Tue Nov 13, 2018 8:34 am

They are included as part of the installer for PowerShell Studio. Please run the installer with the following command line parameters:

Code: Select all

Installer.exe /exenoui /qn /L*v .\SPS_Install.log
This will produce a log of the install process. Please zip and upload the resulting log file here:

https://www.sapien.com/support/upload

It will hopefully give us a better idea what is the cause.
David
SAPIEN Technologies, Inc.

User avatar
IanUoY
Posts: 66
Joined: Wed Jul 31, 2013 2:09 am

Re: Could not find a part of the path....

Post by IanUoY » Wed Nov 14, 2018 6:41 am

I've uploaded the log file, but assuming installed ok as now available.

The recovery issue occurred but have followed the screenshot above and seems to have stopped the issue.

Ian

User avatar
davidc
Posts: 5474
Joined: Thu Aug 18, 2011 4:56 am

Re: Could not find a part of the path....

Post by davidc » Wed Nov 14, 2018 9:36 am

I don't see anything wrong in the logs. I believe the message in the application is the result of a permissions issue.

I would try deleting the recovery folder:

\Application Data\SAPIEN\PowerShell Studio 2018\Recovery\

Otherwise disabling the feature will just prevent the messages.
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5474
Joined: Thu Aug 18, 2011 4:56 am

Re: Could not find a part of the path....

Post by davidc » Wed Nov 14, 2018 9:44 am

BTW You can download the prerequisites from your Registered Products page:

https://www.sapien.com/account/products

The links are located on the right side:
Software Prerequites.png
Software Prerequites.png (38.19 KiB) Viewed 126 times
David
SAPIEN Technologies, Inc.