Information Errors

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
smokingjoe
Posts: 13
Joined: Wed Jul 22, 2015 4:20 am

Information Errors

Post by smokingjoe » Tue Apr 10, 2018 4:04 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build:
PowerShell Studio 2018 v5.5.150

Operating system:
Windows 10 64BIT

*** Please add details and screenshots as needed below. ***
Getting messages like
Information: The cmdlet 'GetObjectsNeedingReporting' returns an object of type 'System.Data.DataSet' but this type is not declared in the OutputType attribute.
Information: The cmdlet 'GetObjectsNeedingXMLReporting' returns an object of type 'System.Data.DataSet' but this type is not declared in the OutputType attribute.
Information: The cmdlet 'GetObjectsJobRequests' returns an object of type 'System.Data.DataSet' but this type is not declared in the OutputType attribute.

However; in the functions define I believe I have this correct?
function GetObjectsNeedingReporting
{
[CmdletBinding(SupportsShouldProcess = $false)]
[OutputType('System.Data.DataSet')]

So I am not sure what I am doing wrong here as this looks like the correct syntax.

cody m

Re: Information Errors

Post by cody m » Tue Apr 10, 2018 2:47 pm

Your output type declaration should be [OutputType([System.Data.DataSet])] rather than [OutputType('System.Data.DataSet')]. That should fix your issue.