Different inscriptions in Add remove program depending of the setup solution

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
DIT-Acquisition
Posts: 23
Joined: Tue Sep 26, 2017 8:05 am

Re: Different inscriptions in Add remove program depending of the setup solution

Post by DIT-Acquisition »

Alexander Riedel wrote:
Fri Oct 06, 2017 11:29 am
Go to this folder: C:\Program Files\SAPIEN Technologies, Inc
What other sub folders are there and do they have content?
See in attachment
Attachments
PoshStudiofiles.txt
(26.23 KiB) Downloaded 56 times

User avatar
Alexander Riedel
Posts: 7458
Joined: Tue May 29, 2007 4:43 pm

Re: Different inscriptions in Add remove program depending of the setup solution

Post by Alexander Riedel »

One folder above. Is there anything else there besides PowerShell Studio? Additionally, is this machine connected to the internet?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
DIT-Acquisition
Posts: 23
Joined: Tue Sep 26, 2017 8:05 am

Re: Different inscriptions in Add remove program depending of the setup solution

Post by DIT-Acquisition »

Alexander Riedel wrote:
Fri Oct 06, 2017 11:56 am
One folder above. Is there anything else there besides PowerShell Studio? Additionally, is this machine connected to the internet?
There is a strange directory at the root of the C:\ but I have no access see screenshot.
Attachments
Directory at root.png
Directory at root.png (299.5 KiB) Viewed 1590 times
Directory at root properties.png
Directory at root properties.png (203.72 KiB) Viewed 1590 times
Directories in program files.png
Directories in program files.png (300.17 KiB) Viewed 1590 times

User avatar
Alexander Riedel
Posts: 7458
Joined: Tue May 29, 2007 4:43 pm

Re: Different inscriptions in Add remove program depending of the setup solution

Post by Alexander Riedel »

Ok, you have shown me C:\Program Files and C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2017 but not the folder I was asking about.

" C:\Program Files\SAPIEN Technologies, Inc" is what I was asking about.

I have no idea what that root folder might be. We do not create that there on purpose. I would suspect that some user is not correctly configured and the user folder defaults to C:\

I have our QA department look into this and see what we can find out.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
DIT-Acquisition
Posts: 23
Joined: Tue Sep 26, 2017 8:05 am

Re: Different inscriptions in Add remove program depending of the setup solution

Post by DIT-Acquisition »

Alexander Riedel wrote:
Fri Oct 06, 2017 12:57 pm
Ok, you have shown me C:\Program Files and C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2017 but not the folder I was asking about.

" C:\Program Files\SAPIEN Technologies, Inc" is what I was asking about.

I have no idea what that root folder might be. We do not create that there on purpose. I would suspect that some user is not correctly configured and the user folder defaults to C:\

I have our QA department look into this and see what we can find out.
Next try
Attachments
program files.png
program files.png (93.74 KiB) Viewed 1574 times

User avatar
Alexander Riedel
Posts: 7458
Joined: Tue May 29, 2007 4:43 pm

Re: Different inscriptions in Add remove program depending of the setup solution

Post by Alexander Riedel »

Ok, we are investigating this. So far this seems to be a Windows 8.x problem, but we need to look some more.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
DIT-Acquisition
Posts: 23
Joined: Tue Sep 26, 2017 8:05 am

Re: Different inscriptions in Add remove program depending of the setup solution

Post by DIT-Acquisition »

Alexander Riedel wrote:
Fri Oct 06, 2017 1:10 pm
Ok, we are investigating this. So far this seems to be a Windows 8.x problem, but we need to look some more.
With a manual installation, everytning seems to be fine.
Unattend seems to be correct (I have Document Explorer 2017, PowerShell Studio 2017, SAPIEN Document Explorer 2017, SAPIEN PowerShell Studio 2017, SAPIEN ScriptMerge 2017, SAPIEN Updates, ScriptMerge 2017)
Under system account it is not correct.

I believe the problem is not with Windows 8.1 but the installer. May be not interpreting correctly the environment as system account is seeing the environment differently.

User avatar
Alexander Riedel
Posts: 7458
Joined: Tue May 29, 2007 4:43 pm

Re: Different inscriptions in Add remove program depending of the setup solution

Post by Alexander Riedel »

It's a run-of-the-mill Windows Installer, there is really nothing special about it. We make no distinction in the installer in regards to the user account.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Olga_B
Site Admin
Posts: 149
Joined: Mon May 15, 2017 9:06 am

Re: Different inscriptions in Add remove program depending of the setup solution

Post by Olga_B »

I ran several tests on Windows 8 VM, and it works fine for me. All products were installed.
But depending of what prerequisites need to be installed it's taking some time.
Have you checked installed products right after command completed?
Did you check if installer still running?

User avatar
DIT-Acquisition
Posts: 23
Joined: Tue Sep 26, 2017 8:05 am

Re: Different inscriptions in Add remove program depending of the setup solution

Post by DIT-Acquisition »

Olga_B wrote:
Fri Oct 06, 2017 2:05 pm
I ran several tests on Windows 8 VM, and it works fine for me. All products were installed.
But depending of what prerequisites need to be installed it's taking some time.
Have you checked installed products right after command completed?
Did you check if installer still running?
Did you test the installation with the system account?
All failure are done Under the system account.
Is it possible to create a log of the installation from your setup program?

This morning I ran more test unattend and attend. When ran Under my account, no problem but with the system account then I got the failures.

I did test with psexec -s -s cmd.exe and then launch the setup.

To solve the issue, I had to get the prerequisite from %appdata%\PowerShellStudio\SAPIEN Technologies, Inc\PowerShell Studio 2017\prerequisites and installed them separately then everything is fine.

I believe you should get a look to this issue or confirm how to get the prerequisites.

Thanks,
Attachments
System_3.png
System_3.png (106.42 KiB) Viewed 1497 times
System_2.png
System_2.png (111.08 KiB) Viewed 1497 times
System_1.png
System_1.png (64.19 KiB) Viewed 1497 times