Powershell Studio Icon problem

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
PGomersall
Posts: 92
Joined: Sun Mar 03, 2013 12:40 pm

Powershell Studio Icon problem

Post by PGomersall » Tue Sep 26, 2017 2:26 pm

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio 2017 5.4.143
32 or 64 bit version of product: 64
Operating system: W10 Education
32 or 64 bit OS: 64

*** Please add details and screenshots as needed below. ***

DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM
On the update a couple of versions ago that had problems I had to uninstall and reinstall. Ever since then I have lost the Icon associated with ps1 files that was previously set to PowerShell Studio - how to get these back?
Regards,
Pete

User avatar
Olga_B
Site Admin
Posts: 134
Joined: Mon May 15, 2017 9:06 am

Re: Powershell Studio Icon problem

Post by Olga_B » Tue Sep 26, 2017 2:51 pm

Hi Pete,

Could you be more specific what icon association are you talking about?
It will be very helpful if you provide some screenshots

Thanks

User avatar
PGomersall
Posts: 92
Joined: Sun Mar 03, 2013 12:40 pm

Re: Powershell Studio Icon problem

Post by PGomersall » Tue Sep 26, 2017 3:30 pm

Previously all ps1 files in Windows Explorer had the default PowerShell Studio Icon. Now after uninstall\reinstall of PowerShell Studio they have the default unknown file type icon as in the attached image.
Attachments
PS-Icons.png
PS-Icons.png (2.87 KiB) Viewed 1478 times

User avatar
Olga_B
Site Admin
Posts: 134
Joined: Mon May 15, 2017 9:06 am

Re: Powershell Studio Icon problem

Post by Olga_B » Tue Sep 26, 2017 4:29 pm

Have you tried to associate them back with PowerShell Studio?
1. Right Click on file and select 'Open With/Choose another app
2. On dialog 'How do you want to open this file?'
- select Sapien Power Shell Studio icon
- check checkbox 'Always use this app to open .ps1 files'
- click OK

Hope this helps

User avatar
PGomersall
Posts: 92
Joined: Sun Mar 03, 2013 12:40 pm

Re: Powershell Studio Icon problem

Post by PGomersall » Wed Sep 27, 2017 11:54 am

This was the first thing I tried which didn't work. Basically it looks like the uninstall\reinstall didn't remove\recreate the DefaultIcon settings in the registry as in this one for example: HKEY_CLASSES_ROOT\SAPIEN.PowerShell Studio 2017.pfs\DefaultIcon. The values for all these (everything related to SAPIAN) were pointing to an installer file not a real executable or ico file. I had to set these all manually by exporting the settings on a working machine and importing them on the broken one.
It would be nice if your uninstall processes worked completely.

User avatar
PGomersall
Posts: 92
Joined: Sun Mar 03, 2013 12:40 pm

Re: Powershell Studio Icon problem

Post by PGomersall » Wed Sep 27, 2017 12:04 pm

So by me editing these values and then upgrading PSS to 144 looks like it now overwrote these value with the correct settings. So it seems all is fixed.