Disable Digital Signature Wizard

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
owinsloe
Posts: 38
Joined: Tue Jul 10, 2012 10:37 am

Disable Digital Signature Wizard

Post by owinsloe » Sun Jul 16, 2017 5:54 pm

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

PowerShell Studio 2017 5.4.141.0
64 bit
Windows 10
64 bit

Hi,
I build packages using a signed cert and this has been working fine upto the certs recent expiry.

I have loaded the new cert and added the cert details script package output settings.

Now when I build the package I am presented with a "Digital Signature Wizard". If I use the wizard, I am able to successfully create my package but I never needed to use this wizard previously and I can not work out how to disable it.

I want to disable it as I have the cert details already loaded (as above).

I have also tried;
loading latest Powershell Studio updates
restarting powershell studio
restarting PC

I used all the default options for the cert install so dont believe there should be a problem there. Is there something else I need to do to disable\suppress the wizard?

Thanks

User avatar
owinsloe
Posts: 38
Joined: Tue Jul 10, 2012 10:37 am

Re: Disable Digital Signature Wizard

Post by owinsloe » Sun Jul 16, 2017 7:37 pm

These are the steps I have to follow to apply the signed cert (attached)

NOTE...I can not select from 'Use the certificate' list on 'Signature Certificate' pane. I have to use the 'Select from Store' button.
Attachments
Untitled.jpg
Untitled.jpg (337.22 KiB) Viewed 149 times

User avatar
Alexander Riedel
Posts: 6221
Joined: Tue May 29, 2007 4:43 pm

Re: Disable Digital Signature Wizard

Post by Alexander Riedel » Sun Jul 16, 2017 8:50 pm

The wizard comes up when the Windows signing component does not know what you want to do. Most likely you left the old signature in your certificate store. Now you have two signature with the same name.
Delete the old signature from your certificate store.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
owinsloe
Posts: 38
Joined: Tue Jul 10, 2012 10:37 am

Re: Disable Digital Signature Wizard

Post by owinsloe » Mon Jul 17, 2017 2:30 pm

Hi Alexander Riedel,
Thanks for the speedy response. No I did not have the old cert present but I found that I was able to correct the problem only after by clicking on the view certificate button (see attachment). It's not obvious that this is a requirement but at least it has cleared the wizard displaying.

Thanks
Attachments
CertDisplay.jpg
CertDisplay.jpg (133.81 KiB) Viewed 119 times