Snippet Editor Bug?

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
dave.wiard
Posts: 17
Joined: Wed Feb 04, 2015 3:14 pm

Snippet Editor Bug?

Post by dave.wiard » Fri May 26, 2017 9:29 am

I have a user snippet that includes the following text.
# Copyright © 2017
When this gets saved to the snippet file it appears to be correctly saved in UTF-8 format (as identified by Visual Studio Code).
<Code Language="PowerShell">
	<![CDATA[# Copyright © 2017
]]>
</Code>
When I return to the Snippet Editor to make changes it does not look right.
# Copyright © 2017
This can be duplicated in every time. Create a new snippet with the copyright symbol, save it, close it, reopen it.

User avatar
dave.wiard
Posts: 17
Joined: Wed Feb 04, 2015 3:14 pm

Re: Snippet Editor Bug?

Post by dave.wiard » Fri May 26, 2017 9:42 am

Also, if I delete the  it returns the next time the snippet is opened. If I do not delete it before saving the file there are two the next time it gets opened.

User avatar
Alexander Riedel
Posts: 6835
Joined: Tue May 29, 2007 4:43 pm

Re: Snippet Editor Bug?

Post by Alexander Riedel » Fri May 26, 2017 10:05 am

Looks like some type of conversion error. We will look into it.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 6835
Joined: Tue May 29, 2007 4:43 pm

Re: Snippet Editor Bug?

Post by Alexander Riedel » Fri May 26, 2017 10:22 am

[Topic moved to correct forum by moderator]
Please makes sure to post in the correct forum to start with. It prevents us from having to come back and ask questions that are listed in the post template.

Please indicate the exact version of the product and the snippet editor you have installed.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
dave.wiard
Posts: 17
Joined: Wed Feb 04, 2015 3:14 pm

Re: Snippet Editor Bug?

Post by dave.wiard » Fri May 26, 2017 2:56 pm

These are the versions I am currently running. This has been happening for some time but I only now have taken the time to post this issue.

PowerShell Studio 2017 v5.4.140

Snippet Editor 1.1.19

User avatar
davidc
Posts: 5725
Joined: Thu Aug 18, 2011 4:56 am

Re: Snippet Editor Bug?

Post by davidc » Tue Jun 27, 2017 11:24 am

This issue should be resolved in the latest service release of PowerShell Studio (v5.4.141).
David
SAPIEN Technologies, Inc.