Support Forums

PrimalScript 2015 Install Error

Support for all customers who have purchased a PrimalScript product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
clum09
Posts: 114
Joined: Thu Apr 24, 2008 9:11 am

PrimalScript 2015 Install Error

Postby clum09 » Fri Jan 15, 2016 1:45 pm

Product, version and build: PrimalScript 2015, 7.1.74_122315
32 or 64 bit version of product: 64-Bit.
Operating system: Windows 7 Professional
32 or 64 bit OS: 64-Bit

I cannot install PrimalScript 2015 on a new computer I just built. I got the error dialog during the installation which stated as follows:

"Warning 4154. Visual C++ Redistributable for Visual Studio 2012 x64 prerequisite was not properly installed. Continue installation of PrimalScript 2015?"

with a Yes and a No button.

When I clicked on Yes, the installation continues, but PrimalScript packaged script from PrimalScript 2015 does not execute the code properly. If I clicked on No, the setup dialog stated that "the installation ends prematurely", and asked me to run the installation again.

Please let me know how I can get this product installed on my computer.

Thanks.
User avatar
DevinL
Site Admin
Posts: 731
Joined: Mon Aug 17, 2015 2:25 pm

Re: PrimalScript 2015 Install Error

Postby DevinL » Fri Jan 15, 2016 1:52 pm

Unfortunately I'm unable to reproduce this on my end.

Have you tried installing the C++ Redistributable and then installing PrimalScript? It's available here:

https://www.microsoft.com/en-us/download/details.aspx?id=30679
DevinL
SAPIEN Technologies, Inc.
User avatar
Alexander Riedel
Posts: 5857
Joined: Tue May 29, 2007 4:43 pm

Re: PrimalScript 2015 Install Error

Postby Alexander Riedel » Fri Jan 15, 2016 9:56 pm

"Packaged script ... does not execute the code properly" is very vague.

What type of script? Packaged how? What constitutes "properly" ? What are the error messages?

The Visual C++ runtime PrimalScript uses for example has no bearing in PowerShell Scripts. If you do not have the correct Powershell version and the .NET run times installed then a package may simply not run at all. But we cannot see from your description if that is the case here. So please provide specific information.
Alexander Riedel
SAPIEN Technologies, Inc.

Return to “PrimalScript”

Who is online

Users browsing this forum: No registered users and 1 guest