Page 1 of 2

Primal script crahes

Posted: Sun Jan 03, 2016 5:43 am
by JMS_PT
Today I received an update for primal script, when I try to access Sapiens page using primal script (Help tab -> "Sapien Home"), and then try to login to the page the system crashes...
I`m using x64 version of primal script.
I`m running Windows 10 x64

Primal Script crashes.png
Primal Script crashes.png (666.9 KiB) Viewed 5742 times

Re: Primal script crahes

Posted: Sun Jan 03, 2016 12:27 pm
by Alexander Riedel
Thank you for letting us know.We will investigate.

Re: Primal script crahes

Posted: Sun Jan 03, 2016 12:35 pm
by Alexander Riedel
Please post the exact build with which this happens, just to make sure we are looking at the same thing.
From your post it is not clear if this is before an update with an unknown build or after the update with the latest build.

Re: Primal script crahes

Posted: Sun Jan 03, 2016 2:00 pm
by JMS_PT
The build is:
build.png
build.png (6.64 KiB) Viewed 5720 times
Also in attach the file for a portion of the memory dump (they all point (I have 4) to the same OCX in the stack)
dmp.txt
(9.92 KiB) Downloaded 204 times

Re: Primal script crahes

Posted: Sun Jan 03, 2016 2:48 pm
by Alexander Riedel
Yes, thank you for the dump files. The exception occurs in the Adobe Flash Player control. This is not part of PrimalScript.
I suggest to disable the Flash plugin in Internet Explorer and try again.

Re: Primal script crahes

Posted: Sun Jan 03, 2016 4:01 pm
by JMS_PT
Yep I tried that when it first happen.
As per
https://helpx.adobe.com/flash-player/kb ... -edge.html
and
https://support.microsoft.com/en-us/kb/3087040
I also confirm the reg setting at
HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\Addons

I know that are some known issues with windows 10 Edge, but I disabled the add-on in Edge, also in IE (because windows 10 also has a hidden IE :)) and in Chrome which is my default browser... Unfortunately the stack always show that Flash.OCX after Primalscript cals the URL, that`s why I posted here to know if you knew anything about this...

I did a quick search and I found MS KB3087040 that does not seem to be related with this issue.

1 note, the page loads ok, the problem/crash only happens if I click in a link like login...

Re: Primal script crahes

Posted: Sun Jan 03, 2016 4:36 pm
by JMS_PT
Here`s what I found so far:
When opening the same page in a browser (Edge or chrome), no problem what so ever...

But with Primal script, SHARING violation occurs when the app creates "NativeCache.directory" inside "C:\Users\username\AppData\Roaming\Adobe\Flash Player\NativeCache"

The browsers, when used without Primal script don`t try to create this cache file... which is used by video (https://helpx.adobe.com/flash-player/kb ... -play.html)?

This appears to happen when the page is loading the social Icons, So I was wondering if you think that may be related with this problem...

Re: Primal script crahes

Posted: Sun Jan 03, 2016 4:57 pm
by Alexander Riedel
I ran a quick test on my machines here and I cannot produce the problem. I will forward the information to our web developers tomorrow morning and see what they can find.

Re: Primal script crahes

Posted: Sun Jan 03, 2016 5:01 pm
by JMS_PT
Ok, thanks, I`m also seeing a lot of bufferoverflows in the stack... So at this point is not very clear what is going on.
Later I`ll try a live debug to try to figure out what`s going on, let me know if you have news on this.

Re: Primal script crahes

Posted: Sun Jan 03, 2016 5:43 pm
by Alexander Riedel
PrimalScript just uses an IE object for this, not sure what would cause a difference. We will know more when the web devs get their hands on this.