PrimalScript always opens Maximized

Support for all customers who have purchased a PrimalScript product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
sblaylock
Posts: 33
Joined: Tue May 31, 2011 5:00 am

PrimalScript always opens Maximized

Post by sblaylock » Tue Sep 05, 2017 11:44 am

7.3.106_080217_x64
Windows 7 64 bit.

When I open PrimalScript via the icon it always opens Maximized. However, if I right click the icon and "Run as administrator", it opens in the last size I had it before closing. If I click a file with an associated extension eg .js or .java, PrimalScript will open in the last size I had it in.

"Maximize edit windows on open" is not checked.

This was reported as a bug several years ago and was supposed to be fixed in "the next release". However, it seems to still be happening on my system. Is there a registry setting that needs to be changed or cleaned up?

Thanks,
Scott.

User avatar
Alexander Riedel
Posts: 6361
Joined: Tue May 29, 2007 4:43 pm

Re: PrimalScript always opens Maximized

Post by Alexander Riedel » Tue Sep 05, 2017 11:57 am

When you say "via the icon" I am assuming that you mean the shortcut on your desktop.
Windows shortcuts have a property that determines which size the application opens. I would surmise it is set to "Maximize" from your description.
If you right click and select properties, you can determine that any which way you like.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
sblaylock
Posts: 33
Joined: Tue May 31, 2011 5:00 am

Re: PrimalScript always opens Maximized

Post by sblaylock » Tue Sep 05, 2017 1:00 pm

That was it! Thanks.

Question - why would the install process set it up that way. PrimalXML, ScriptMerge and Sapien Document Explorer all installed fine with the Run option as 'normal window'. I had removed and reinstalled to see if that would fix it, but it was still opening Maximized.

Scott.

User avatar
Alexander Riedel
Posts: 6361
Joined: Tue May 29, 2007 4:43 pm

Re: PrimalScript always opens Maximized

Post by Alexander Riedel » Tue Sep 05, 2017 1:16 pm

Mostly because I decided it would be best if PrimalScript would come up maximized the first time someone used it.
Its easy enough to change if someone doesn't like it.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
sblaylock
Posts: 33
Joined: Tue May 31, 2011 5:00 am

Re: PrimalScript always opens Maximized

Post by sblaylock » Tue Sep 05, 2017 1:52 pm

Ahhh... OK.

I thought it was something to do with my install. What was odd was the Run as administrator option didn't have it open Maximized.

Anyway, thanks for the help,
Scott.