Date Format Issue when run in PrimalScript

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
wayne_Avery
Posts: 27
Joined: Mon Sep 27, 2010 12:43 pm

Date Format Issue when run in PrimalScript

Post by wayne_Avery » Wed Feb 08, 2017 6:54 am

Product, version and build: PrimalScript 2017, Version 7.3.98
32 or 64 bit version of product:64 Bit
Operating system:
32 or 64 bit OS:Win10 64Bit

I am writing a PowerShell script that deals with date calculations and reading and writing dates to CSV files. Being located in Australia our date format is dd/mm/yyyy. What I have found is that when I run these scripts in the PrimalScript application it gets confused because it keeps reverting to American date format. If I run the same script from the PowerShell command line it works fine. Is there a setting in the PrimalScript application that sets the locality globally.
Thanks in Advance
Wayne

DevinL
Site Admin
Posts: 1098
Joined: Mon Aug 17, 2015 2:25 pm

Re: Date Format Issue when run in PrimalScript

Post by DevinL » Wed Feb 08, 2017 10:21 am

Can you provide an example of where this causes a problem? Perhaps you can upload one of these scripts that you mention?

If you prefer, you can upload it to http://sapien.com/support/upload if you don't wish for the code to get out.
DevinL
SAPIEN Technologies, Inc.

User avatar
wayne_Avery
Posts: 27
Joined: Mon Sep 27, 2010 12:43 pm

Re: Date Format Issue when run in PrimalScript

Post by wayne_Avery » Thu Feb 09, 2017 5:32 am

Thanks for the reply but it seems I was hasty posting this ;ate last night. After a nap I have found the issue in the code.
Cheers
Wayne

DevinL
Site Admin
Posts: 1098
Joined: Mon Aug 17, 2015 2:25 pm

Re: Date Format Issue when run in PrimalScript

Post by DevinL » Thu Feb 09, 2017 5:21 pm

Glad to hear the issue was resolved, and that it wasn't a bug in the product ;)

If you have any further issues, please don't hesitate to post again.
DevinL
SAPIEN Technologies, Inc.