Page 1 of 1

End of line in PrimalPad 2012

Posted: Fri Jan 31, 2014 3:06 am
by r.massone
I really like PrimalPad and I use it as a lightweight editor beside PrimalScript but there's a setting a really can't find: End of line settings.

Sometimes it's really important to preserve the current EOL settings of a file but PrimalPad seems to replace all the EOL sequences with an LF.
I tried to find a way to change PrimalPad behaviour but I couldn't find it in the Options dialog nor in the ribbon.

Is it actually possible to have PrimalPad respect the current EOL settings of a file or, alternatively, to select a different one?

Thanks.

Kind regards,
--
Renato Massone

Re: End of line in PrimalPad 2012

Posted: Fri Jan 31, 2014 4:15 am
by Alexander Riedel
It shouldn't do that. I will look into it.

Re: End of line in PrimalPad 2012

Posted: Fri Jan 31, 2014 5:00 am
by Alexander Riedel
Download the latest (2.1.34) and see if that is any help.

Re: End of line in PrimalPad 2012

Posted: Sat Feb 01, 2014 6:02 am
by r.massone
Alexander,

I checked the latest version (x64 and x86) and now it is OK.
It actually maintain the current EOL of the file.

Curiously, even if they are digitally signed on 31 January 2014, the file timestamp within the zip file is 15/08/2012. ;-)

Thanks.

Kind regards,
--
Renato Massone