Search found 17 matches

by dave.wiard
Wed Sep 23, 2015 8:31 am
Forum: PowerShell Studio
Topic: Auto-Insert Behavior
Replies: 1
Views: 1249

Auto-Insert Behavior

This is more of an annoyance than anything else. In several other editors (most notably Visual Studio 2013) the other editors behave differently with respect to auto-inserts. When I insert a " in both PowerShell Studio and Visual Studio, they both auto-insert a matching ". The difference comes when ...
by dave.wiard
Thu Feb 19, 2015 1:33 pm
Forum: PowerShell Studio
Topic: Syntax Highlighting
Replies: 4
Views: 1268

Re: Syntax Highlighting

Since my original post, the syntax highlighting has corrected itself. I don't know why it was broken or how it fixed itself but it seems to be fine now.
by dave.wiard
Thu Feb 19, 2015 11:07 am
Forum: PowerShell Studio
Topic: Syntax Highlighting
Replies: 4
Views: 1268

Syntax Highlighting

The following line of code is not being parsed correctly for syntax highlighting. The first `" is seen as an end to the first " which throws the syntax highlighting off. The parser opens a new quoted string at the fourth " which throws off the highlighting throughout the rest of the file. $Options =...
by dave.wiard
Fri Feb 13, 2015 12:42 pm
Forum: PowerShell Studio
Topic: Syntax Highlighting
Replies: 2
Views: 859

Syntax Highlighting

It seems that PowerShell Studio 2015 (4.2.80, 64-bit) does not recognize #region as being a reserved word. It treats it as a comment for syntax highlighting purposes. It would be nice if #region (and #endregion) could be recognized so it doesn't show as the same color as a comment, so it stands out ...
by dave.wiard
Fri Feb 06, 2015 8:36 am
Forum: PowerShell Studio
Topic: Unable To Load Script Files
Replies: 7
Views: 1599

Re: Unable To Load Script Files

Thank you for the very quick fix. Everyone on our team will be very happy to be working in PowerShell Studio again! With the new build every script file I've tried to load has loaded correctly.
by dave.wiard
Thu Feb 05, 2015 2:46 pm
Forum: PowerShell Studio
Topic: Unable To Load Script Files
Replies: 7
Views: 1599

Re: Unable To Load Script Files

I didn't notice that I had copied and pasted the activation number and not the build number. My apologies. I have updated the original post with the build number.
by dave.wiard
Thu Feb 05, 2015 1:23 pm
Forum: PowerShell Studio
Topic: Unable To Load Script Files
Replies: 7
Views: 1599

Unable To Load Script Files

We just updated to PowerShell Studio 2015 64-bit version running on Windows 8.1 (and others). Every time we try to load several of our script files we get an error stating "Object reference not set to an instance of an object." If we open an empty file and copy/paste the script contents from another...