Search found 7335 matches

by Alexander Riedel
Sun Mar 15, 2020 7:49 pm
Forum: PowerShell Studio
Topic: Unsupported Encoding when building exe
Replies: 7
Views: 512

Re: Unsupported Encoding when building exe

Please check what your default file encoding is in PowerShell Studio.
by Alexander Riedel
Fri Mar 13, 2020 7:28 am
Forum: PowerShell Studio
Topic: Get-Package is not working in Forms
Replies: 3
Views: 526

Re: Get-Package is not working in Forms

Give it a few days and we can test this with PS 7.
by Alexander Riedel
Wed Mar 11, 2020 5:18 am
Forum: Former and Future Customers - Questions
Topic: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5
Replies: 12
Views: 23093

Re: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5

I cannot execute third party executable for security reasons. Please follow my earlier instructions.
by Alexander Riedel
Tue Mar 10, 2020 11:26 am
Forum: Former and Future Customers - Questions
Topic: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5
Replies: 12
Views: 23093

Re: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5

Ok, I am gonna break this to you as gentle as I can. I wrote the packager code and the code for the hosts, so chances are, I do know a little bit more about it than you. So instead of telling me that what I do is no good, how about you follow my lead here. I packaged your code with a Windows host an...
by Alexander Riedel
Tue Mar 10, 2020 9:48 am
Forum: PrimalScript
Topic: Unable to create 32-bit com objects after upgrade to 2020
Replies: 8
Views: 1766

Re: Unable to create 32-bit com objects after upgrade to 2020

Well you were debugging, not running. That is an entirely different ball of wax. FWIW, Run in Shell runs in the current shell. If you want a 32 bit shell, you need to select that from the combo box. There are a number of components that have trouble with debugging. The Microsoft components that are ...
by Alexander Riedel
Tue Mar 10, 2020 9:10 am
Forum: Former and Future Customers - Questions
Topic: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5
Replies: 12
Views: 23093

Re: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5

What do you mean my tests are not going well? It's not a compiler. It just runs powershell in a host on your machine.
I packaged with the same packager you use and the code you provided.
Run the exe I packaged here on YOUR machine and see what it does.
by Alexander Riedel
Tue Mar 10, 2020 8:38 am
Forum: PowerShell Studio
Topic: Get-Package is not working in Forms
Replies: 3
Views: 526

Re: Get-Package is not working in Forms

getpackage.png
getpackage.png (13.59 KiB) Viewed 518 times
Appears to operate fine.

$button1_Click={
#TODO: Place custom script here
$textbox1.Text = Get-Command get-package | Out-String
}
by Alexander Riedel
Tue Mar 10, 2020 6:47 am
Forum: Former and Future Customers - Questions
Topic: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5
Replies: 12
Views: 23093

Re: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5

Does not display any such message.
preparetest.png
preparetest.png (8.39 KiB) Viewed 12865 times
preparetest cmd.png
preparetest cmd.png (10.78 KiB) Viewed 12865 times
by Alexander Riedel
Mon Mar 09, 2020 1:03 pm
Forum: Former and Future Customers - Questions
Topic: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5
Replies: 12
Views: 23093

Re: BUG BUILDING EXE WITH SCRIPT ENGINE POWERSHELL 5

The message 'Preparing modules for first use.' is a Powershell message that stems from auto-loading custom modules. Examine your script for modules used and load them explicitly on startup. That usually helps the problem. Please understand that this is powershell output and has nothing to do with th...
by Alexander Riedel
Mon Mar 09, 2020 6:56 am
Forum: Windows PowerShell
Topic: Powershell 7 or new instances of PS
Replies: 8
Views: 1680

Re: Powershell 7 or new instances of PS

It doesn't really matter if there are differences or limitations. Many organizations will not allow updating or adding PowerShell 7 to their machines for quite some time. So we will keep supporting Windows PowerShell 5.1