Search found 1209 matches

by brittneyr
Fri Oct 07, 2022 6:45 am
Forum: PowerShell Studio
Topic: Clicking on the error message opens the .run.ps1 and not where the error is
Replies: 2
Views: 50

Re: Clicking on the error message opens the .run.ps1 and not where the error is

Technically, it's not pointing to the wrong file. If you are using a psf or project, your files are automatically exported to a ps1 on run. For more information about this, the following may be helpful: https://www.sapien.com/blog/2022/03/15/powershell-studio-projects-introduction/ https://www.sapie...
by brittneyr
Thu Oct 06, 2022 7:06 am
Forum: PowerShell GUIs
Topic: Checkedlistbox change color when item checked
Replies: 12
Views: 140

Re: Checkedlistbox change color when item checked

[Topic moved by moderator to PowerShell GUIs forum]
by brittneyr
Wed Oct 05, 2022 7:35 am
Forum: PowerShell Studio
Topic: PS Studio issues with Get-InstalledLanguage
Replies: 3
Views: 116

Re: PS Studio issues with Get-InstalledLanguage

The issue appears to only happen when using the LanguagePackManagement module with a GUI or WinForm. I've tested this in Visual Studio Code and ISE, but it results in the same error. Basic scripts appear to run fine. My guess is that this module has conflict with a GUI's thread. While this may chang...
by brittneyr
Tue Oct 04, 2022 1:30 pm
Forum: PowerShell Studio
Topic: PS Studio issues with Get-InstalledLanguage
Replies: 3
Views: 116

Re: PS Studio issues with Get-InstalledLanguage

I'm having a hard time reproducing this behavior:
SPS-GetInstalledLanguage.png
SPS-GetInstalledLanguage.png (70.33 KiB) Viewed 98 times
Can you please provide a screenshot of the application with the error when you attempt to run your script?
by brittneyr
Tue Oct 04, 2022 6:39 am
Forum: PowerShell Studio
Topic: connect-exchangeonline -userprincipalname doesn't bring up MFA browser
Replies: 1
Views: 69

Re: connect-exchangeonline -userprincipalname doesn't bring up MFA browser

This is a problem with PowerShell v5.1 and the ExchangeOnlineManagement module being version 2.0.4 or later. There is a little we can do to help with this as these are both Microsoft. The only known fixes are to downgrade ExchangeOnlineManagement or upgrade to use PowerShell 7. Reporting and getting...
by brittneyr
Mon Oct 03, 2022 10:14 am
Forum: Former and Future Customers - Questions
Topic: using assembly for The members of the class cannot be displayed
Replies: 3
Views: 924

Re: using assembly for The members of the class cannot be displayed

Thank you for reporting. I have created a bug report for the issues mentioned here for the development team and will update you when I have more information.
by brittneyr
Tue Sep 27, 2022 12:59 pm
Forum: PowerShell Studio
Topic: Add child form to wizzard style form script
Replies: 2
Views: 340

Re: Add child form to wizzard style form script

You can create your form or psf file, export it to a ps1, and then dot source the exported file. Then you should be able to call the reference function for the form. This may get annoying as anytime you make changes to the form, you would need to export to a ps1 again. I recommend creating a new pro...
by brittneyr
Fri Sep 23, 2022 3:11 pm
Forum: VersionRecall
Topic: Deleted or moved files keep re-appearing
Replies: 9
Views: 678

Re: Deleted or moved files keep re-appearing

We have received your file.
Under your VersionRecall repository properties, please try disabling Synchronize newer files.
by brittneyr
Thu Sep 22, 2022 8:31 am
Forum: PowerShell Studio
Topic: Add an additional form to a single form
Replies: 1
Views: 336

Re: Add an additional form to a single form

I recommend creating a new project and adding your existing psf file to the project: SPS_ProjectPaneAddExisting.png The following articles may be helpful: https://www.sapien.com/blog/2022/01/04/basics-working-with-a-psf-file-in-powershell-studio/ https://www.sapien.com/blog/2022/08/03/powershell-stu...