Search found 19 matches

by ashishk
Fri Apr 07, 2017 10:29 am
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

Hi My original code which I posted in my first post was, I was getting same error here as well $logLocal = "c:\users\$Env:USERNAME\AppData\Local\MyLogs\" $centralizedLocation = "c:\appLogs\" $copyLog=$logLocal +$Env:USERNAME+"_"+ "AdminActivity" +"_"+$logDate +".txt" $filename = Split-Path $copyLog ...
by ashishk
Thu Apr 06, 2017 10:54 pm
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

Hi jvierra Following code suggested by and it seems to be perfect, there is nothing wrong in the variable but I am still getting error when I run it as compiled exe, however file is getting copy. Secondly I direct run as script instead of compiled exe, I don't get any error. $logLocal = "c:\users\$E...
by ashishk
Wed Apr 05, 2017 7:36 pm
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

Hello

Has anyone found the solution?

I am still stuck on same issue, I tested this in PS 2.0/4.0/5.0, everywhere it is same issue.

Any other approach to resolve this issue?
by ashishk
Tue Apr 04, 2017 10:09 pm
Forum: Former and Future Customers - Questions
Topic: You must provide a value expression on the right-hand side of the '-' operator
Replies: 5
Views: 13817

Re: You must provide a value expression on the right-hand side of the '-' operator

Alexender

I found the problem, actually -notin element is not supported in PowerShell 2.0. So I used -notcontains element and it works.

Secondly as you said about $formatedSheetData, actually it will never empty because csv which I am porting always have two rows.
by ashishk
Tue Apr 04, 2017 4:25 am
Forum: Former and Future Customers - Questions
Topic: You must provide a value expression on the right-hand side of the '-' operator
Replies: 5
Views: 13817

Re: You must provide a value expression on the right-hand side of the '-' operator

Alenxender

To get the license version, I already raised a request to my purchase report to buy the license.

However if you see below code, I am getting error in row 20.
by ashishk
Tue Apr 04, 2017 12:36 am
Forum: Former and Future Customers - Questions
Topic: You must provide a value expression on the right-hand side of the '-' operator
Replies: 5
Views: 13817

You must provide a value expression on the right-hand side of the '-' operator

Product, version and build: (*** Please do not write "latest" as a version, specify a version number ***) 32 or 64 bit version of product: 64 Operating system: Widnows 7 32 or 64 bit OS:64 DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM Using PrimalScript I compiled ...
by ashishk
Mon Apr 03, 2017 3:43 am
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

Fortunately both the location or directory are available.
by ashishk
Sun Apr 02, 2017 8:11 pm
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

OK, I tested your code as well, but getting same error. ERROR: Program 'Robocopy.exe' failed to run: The method or operation is not ERROR: implemented.At line:12 char:1 ERROR: + robocopy $LogLocal $CentralizedLocation $Filename ERROR: + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~. ERROR: At li...
by ashishk
Sat Apr 01, 2017 11:48 am
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

Hi jvierra I shared only sample file to provide about the issue. I also tested for copy directory and its subfolders using following robocopy syntex, but unfortunately getting same error. Robocopy $sourceFolderPath $pathDir Secondly I can use copy-item as well especially when you are using mulfiple ...
by ashishk
Fri Mar 31, 2017 11:30 am
Forum: Windows PowerShell
Topic: robocopy is giving error with compiled script
Replies: 27
Views: 37277

Re: robocopy is giving error with compiled script

Thanks DevinL

I tried with PowerShell command windows as well command windows infact run as Administrator.

I did not found anything in log viewer as well.

I will wait for your update.