Search found 10 matches

by simon.briggs
Mon Sep 24, 2018 5:01 am
Forum: PowerShell GUIs
Topic: POSH-SSH module is not functioning from a button press on a form
Replies: 6
Views: 872

Re: POSH-SSH module is not functioning from a button press on a form

Just found the issue, the variables which build the ssh commands aren't populating the scriptblock. The SSH sessions are returning information but it wasn't being displayed.
by simon.briggs
Mon Sep 24, 2018 4:57 am
Forum: PowerShell GUIs
Topic: POSH-SSH module is not functioning from a button press on a form
Replies: 6
Views: 872

Re: POSH-SSH module is not functioning from a button press on a form

output from the command should be in the form of Host: server Output: {results} Exitstatus: exitcode I am not familiar with the debugging process I'm afraid. I was expecting it to output everything in the debug window. I set the breakpoint on the line of the command then stepped through the function...
by simon.briggs
Mon Sep 24, 2018 1:25 am
Forum: PowerShell GUIs
Topic: POSH-SSH module is not functioning from a button press on a form
Replies: 6
Views: 872

Re: POSH-SSH module is not functioning from a button press on a form

Tried running through debug, nothing is coming up in the debug console. Apologies if I am missing something.
by simon.briggs
Thu Sep 20, 2018 5:50 am
Forum: PowerShell GUIs
Topic: POSH-SSH module is not functioning from a button press on a form
Replies: 6
Views: 872

Re: POSH-SSH module is not functioning from a button press on a form

Apologies for the lack of response, I've been out of office. I'll try it on Monday morning and post results.
by simon.briggs
Tue Sep 18, 2018 7:39 am
Forum: PowerShell GUIs
Topic: POSH-SSH module is not functioning from a button press on a form
Replies: 6
Views: 872

POSH-SSH module is not functioning from a button press on a form

Win7 64bit Sapien Powershell Studio 2018, v 5.5.154 I have created a form that should call on the POSH-SSH module to run some UNIX commands. The script runs fine by itself and is picked up by the powershell studio IDE. It auto-completes the commands that are available through having the module loade...
by simon.briggs
Mon Dec 11, 2017 1:30 am
Forum: Windows PowerShell
Topic: Trying to pass variables to a command line exe
Replies: 1
Views: 787

Trying to pass variables to a command line exe

I'm trying to pass variables to openfiles.exe but it is failing. I've tested the same code from the powershell ISE and it works without issue. Error: ERROR: openfiles.exe : ERROR: Invalid ID. MainForm.psf (490, 4): ERROR: At Line: 490 char: 4 ERROR: + openfiles.exe /disconnect /s SERVER /ID $fi ERRO...
by simon.briggs
Mon Nov 14, 2016 8:46 am
Forum: PowerShell GUIs
Topic: Passing form variable to a script to then return a result back to the form
Replies: 3
Views: 579

Re: Passing form variable to a script to then return a result back to the form

Update: Having realised that I can't use a variable to define a parameter I have changed to using script variables instead.

testing now to confirm that it is working but it looks to have resolved my issue.
by simon.briggs
Mon Nov 14, 2016 7:57 am
Forum: PowerShell GUIs
Topic: Passing form variable to a script to then return a result back to the form
Replies: 3
Views: 579

Passing form variable to a script to then return a result back to the form

Product, version and build: PSS 2016 5.2.129 32 or 64 bit version of product: 64 Operating system: Win 7 Enterprise 64bit PowerShell Version:5 I am trying to pass textbox.text to a script to run a command which will then return a result to the parent form. The command needs to be run by script becau...
by simon.briggs
Tue Oct 25, 2016 6:45 am
Forum: PowerShell Studio
Topic: CMD command not returning results in a Form
Replies: 1
Views: 526

Re: CMD command not returning results in a Form

Found the answer by including a script file and calling it from the form.

Call-script_ps1 | Out-Default

The above returns the expected data.
by simon.briggs
Tue Oct 25, 2016 6:26 am
Forum: PowerShell Studio
Topic: CMD command not returning results in a Form
Replies: 1
Views: 526

CMD command not returning results in a Form

Hello all After searching I can't find anything that covers this issue. I am trying to put together an app for our service desk to use to unlock files on our NAS. I'm trying to use 'openfiles /Query /S <server> /FO CSV' to pull the list of open files from the NAS. This code works by itself when run ...