Search found 7060 matches

by Alexander Riedel
Wed Oct 23, 2019 9:33 am
Forum: PowerShell Studio
Topic: PowerShell Studio Debugger Not Working
Replies: 9
Views: 93

Re: PowerShell Studio Debugger Not Working

I have handed this to QA to create a multi-form project and see what they can find out. Please stand by
by Alexander Riedel
Wed Oct 23, 2019 9:21 am
Forum: PowerShell Studio
Topic: PowerShell Studio Debugger Not Working
Replies: 9
Views: 93

Re: PowerShell Studio Debugger Not Working

Ok, an important first step. So breakpoints basically work in general.
Can you place a breakpoint at the entrance to your app, where the first form is shown, and see if it stops there?
by Alexander Riedel
Wed Oct 23, 2019 8:29 am
Forum: PowerShell Studio
Topic: PowerShell Studio Debugger Not Working
Replies: 9
Views: 93

Re: PowerShell Studio Debugger Not Working

Maybe there is a misunderstanding. What I asked for is a complete sample script that illustrates where you put a breakpoint and where it does not stop. Not a fragment and not code we cannot run here because it relies on your environment. If I paste your button handler into another form, clean out al...
by Alexander Riedel
Tue Oct 22, 2019 11:52 pm
Forum: PowerShell Studio
Topic: Problems debugging in PS V2
Replies: 4
Views: 128

Re: Problems debugging in PS V2

Sorry, not at the moment. The code in question is about as old as PowerShell V2 and always worked. Some recent change in either PowerShell or the .NET framework broke it, at least that is our theory. So we have the fix in QA at this time and are testing all V2 debugging functionality to make sure no...
by Alexander Riedel
Tue Oct 22, 2019 10:40 pm
Forum: Customer Service
Topic: Cannot activate on new Windows install
Replies: 3
Views: 56

Re: Cannot activate on new Windows install

I can see that there have been multiple attempts with your user id, but I can only tell that the password was considered not correct.
I will forward this to the web folks to investigate.
by Alexander Riedel
Tue Oct 22, 2019 4:22 pm
Forum: Former and Future Customers - Questions
Topic: Jobs created in a PowerShell service display differently in Task Manager
Replies: 1
Views: 62

Re: Jobs created in a PowerShell service display differently in Task Manager

First of all, a process is always an independent entity. Since you are creating a new process using Start-Job, which is a Microsoft PowerShell CmdLet, you should probably ask there what exactly they do behind the scenes. The most likely explanation is that if you start a job from a console, stdin, s...
by Alexander Riedel
Tue Oct 22, 2019 11:48 am
Forum: PowerShell Studio
Topic: PowerShell Studio Debugger Not Working
Replies: 9
Views: 93

Re: PowerShell Studio Debugger Not Working

There is an issue specific to V2 that we have recently been made aware of. The issue was introduced by recent changes in the PowerShell engine or in the .NET framework used. We have isolated and already fixed this issue. Just in case someone else is reading this :D At any rate, this does not in any ...
by Alexander Riedel
Mon Oct 21, 2019 8:09 am
Forum: VersionRecall
Topic: Default Integrated Repository to PSStudio
Replies: 3
Views: 112

Re: Default Integrated Repository to PSStudio

It's not really clear what configuration you have here. Can you elaborate maybe we real folder names?
It sounds like you are trying to use nested repositories.
by Alexander Riedel
Fri Oct 18, 2019 9:39 am
Forum: PowerShell Studio
Topic: start-Process doesn't work for executable with dll's
Replies: 1
Views: 171

Re: start-Process doesn't work for executable with dll's

I am not sure what you mean by "can we upload .dll somewhere in Powershell studio?" If your application has dependencies, like a dll for example, you should consider making an MSI for distribution. There you would add the dll and any other needed files. Keep in mind that Start-Process is not a Power...
by Alexander Riedel
Wed Oct 16, 2019 4:06 pm
Forum: PowerShell Studio
Topic: Can I get a Powershell script to execute in MSI file
Replies: 10
Views: 373

Re: Can I get a Powershell script to execute in MSI file

Change it to deferred. Immediately will try to execute the script when the MSI is launched, at which point the script hasn't even been copied yet.