Search found 5190 matches

by davidc
Fri May 18, 2018 8:44 am
Forum: PowerShell Studio
Topic: psbuild does not build a working .exe file.
Replies: 3
Views: 167

Re: psbuild does not build a working .exe file.

For the projects, there isn't a command line option at this time, but it is on our TODO list.

An alternate method would be to export the project to a ps1 file and automate the building of the exported script instead.
by davidc
Thu May 17, 2018 3:02 pm
Forum: PowerShell Studio
Topic: psbuild does not build a working .exe file.
Replies: 3
Views: 167

Re: psbuild does not build a working .exe file.

Since this is a project, you must run it from PowerShell Studio, because the script needs to be generated in order for PSBuild to package it.

Note: This also includes psf files.
by davidc
Thu May 17, 2018 1:41 pm
Forum: PowerShell Studio
Topic: "Run" or "Run In Console"
Replies: 12
Views: 669

Re: "Run" or "Run In Console"

For testing purposes, what happens if you use Invoke-WebRequest instead? Does it also produce the same error?
by davidc
Thu May 17, 2018 1:24 pm
Forum: PowerShell Studio
Topic: "Run" or "Run In Console"
Replies: 12
Views: 669

Re: "Run" or "Run In Console"

I'm convinced, no need for the remote session. I'm just trying to isolate the problem to a particular host so I can have the Dev team investigate. I'm also trying to reproduce this on my end. I noticed you have STA mode checked. Out of curiosity, can you uncheck that option to see if it makes a diff...
by davidc
Thu May 17, 2018 9:06 am
Forum: PowerShell Studio
Topic: Running in Studio works, but built exe file do not
Replies: 1
Views: 110

Re: Running in Studio works, but built exe file do not

Do you get a specific error? I will need more details to understand what is happening, because scripts written for V2 will work in later versions of PowerShell without modifications (the exception maybe being PowerShell Core). As for an exe file, you can always package a script using a PowerShell V2...
by davidc
Thu May 17, 2018 9:04 am
Forum: PowerShell Studio
Topic: MSI Installer Module issues
Replies: 5
Views: 218

Re: MSI Installer Module issues

Please file a Feature Request:

https://www.sapien.com/requests

Thank you,
by davidc
Thu May 17, 2018 8:39 am
Forum: PowerShell Studio
Topic: How to remove the often annoying PowerShell Studio File-Extension association?
Replies: 1
Views: 111

Re: How to remove the often annoying PowerShell Studio File-Extension association?

Try setting the following environmental variable before installing or upgrading:
  1. $env:SKIP_FILEASSOCIATION = '1'
The installer should see the variable and disable the file association.
by davidc
Thu May 17, 2018 8:24 am
Forum: PowerShell Studio
Topic: "Run" or "Run In Console"
Replies: 12
Views: 669

Re: "Run" or "Run In Console"

Out of curiosity, what happens when you package the script into an executable? Try the both the Console and the Windows Application engines.

Also, test running the script from the ISE. I just want to try this in some different hosts to see if it is only our hosts or if others are affected.
by davidc
Tue May 15, 2018 2:52 pm
Forum: PowerShell Studio
Topic: "Run" or "Run In Console"
Replies: 12
Views: 669

Re: "Run" or "Run In Console"

It could be that the Uri is getting decoded ( E.g. %5C to \) and in the other case it is not. I'm not sure what would cause the difference. Do you get the same error if you use the Run Selection command? Also, try adding this at the end of your script that fails: foreach ($item in $Error) { if ($nul...