Search found 5059 matches

by davidc
Fri Feb 23, 2018 1:53 pm
Forum: PowerShell GUIs
Topic: output issues
Replies: 1
Views: 53

Re: output issues

[TOPIC MOVED TO POWERSHELL GUIS FORUM BY MODERATOR]

In order to display the results in a textbox you must first convert it into a string. You can also use Format-Table to change the layout of the results.

Code: Select all

$GetResults  = $GetResults  | Out-String
$richtextbox_Output.AppendText($GetResults )
by davidc
Thu Feb 22, 2018 10:00 am
Forum: PowerShell GUIs
Topic: ProgressbarOverlay problems
Replies: 1
Views: 121

Re: ProgressbarOverlay problems

[TOPIC MOVED TO POWERSHELL GUIS BY MODERATOR]

This article may help:

https://info.sapien.com/index.php/guis/ ... sive-loops
by davidc
Wed Feb 21, 2018 4:37 pm
Forum: PowerShell Studio
Topic: Missing Assembly: Mono.Security
Replies: 9
Views: 385

Re: Missing Assembly: Mono.Security

Thank you, that will help us pinpoint the problem.

As for the other database connections, you can put in a feature request and we will see what we can do:

https://www.sapien.com/requests
by davidc
Wed Feb 21, 2018 3:23 pm
Forum: PowerShell Studio
Topic: Missing Assembly: Mono.Security
Replies: 9
Views: 385

Re: Missing Assembly: Mono.Security

We will investigate and get back to you as soon as we have an update.
by davidc
Wed Feb 21, 2018 3:01 pm
Forum: PowerShell Studio
Topic: Heat.exe error when attempting .msi build.
Replies: 2
Views: 183

Re: Heat.exe error when attempting .msi build.

The MSI settings is pointing the icon in the old 2017 directory. If you go to Ribbon->Deploy->Installer->Settings, you can update the product icon there.

In the next service release, we will add some code to automatically update the path to 2018.
by davidc
Wed Feb 21, 2018 2:51 pm
Forum: PowerShell Studio
Topic: Missing Assembly: Mono.Security
Replies: 9
Views: 385

Re: Missing Assembly: Mono.Security

Yes, it seems the dll was accidentally removed from the installer. It will be included in the next service release.
by davidc
Wed Feb 21, 2018 2:32 pm
Forum: PowerShell Studio
Topic: Missing Assembly: Mono.Security
Replies: 9
Views: 385

Re: Missing Assembly: Mono.Security

PowerShell Studio itself needs the assembly. Copy the dll into PowerShell Studio's directory:

C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2018\

Adding the assembly to the Editor Assemblies, is for PrimalSense and the generated scripts only.
by davidc
Wed Feb 21, 2018 12:52 pm
Forum: PowerShell Studio
Topic: Missing Assembly: Mono.Security
Replies: 9
Views: 385

Re: Missing Assembly: Mono.Security

Try adding this assembly to PowerShell Studio's installation folder and let us know if the issue persists.
Mono.Security.zip
(111.59 KiB) Downloaded 5 times
by davidc
Tue Feb 20, 2018 3:54 pm
Forum: Wish List and Feature Requests
Topic: Unix-style line endings in PowerShell Studio
Replies: 4
Views: 696

Re: Unix-style line endings in PowerShell Studio

You can now alter the file's line endings using the status bar:

https://www.sapien.com/blog/2018/02/20/ ... -v5-5-149/
by davidc
Tue Feb 20, 2018 11:14 am
Forum: PowerShell HelpWriter
Topic: "Confirm" switch parameter is not generated in Help xml files
Replies: 4
Views: 387

Re: "Confirm" switch parameter is not generated in Help xml files

We just released a PowerShell HelpWriter service build (v2.2.38), that includes the Confirm and WhatIf parameters.