Search found 18 matches

by JohnMoe
Wed Jun 03, 2020 11:06 pm
Forum: PowerShell Studio
Topic: Menu disappears when "Add" is clicked
Replies: 2
Views: 403

Menu disappears when "Add" is clicked

Product: PowerShell Studio 2020 (64 Bit) Build: v5.7.178 OS: Windows 10 Pro (64 Bit) Build: v10.0.18363.0 When working on a project, if I right-click the project root and click "Add" to bring up the next menu more quickly (a Windows habit I acquired many years ago to bypass the popup delay), the ent...
by JohnMoe
Mon May 11, 2020 7:06 pm
Forum: Wish List and Feature Requests
Topic: PowerShell spacing option between type and name
Replies: 1
Views: 562

PowerShell spacing option between type and name

Currently, when I define a variable like this:

Code: Select all

[System.String] $myString
PowerShell Studio keeps "correcting" it to:

Code: Select all

[System.String]$myString
In my view, this mashes it together and makes it less readable. Can you please add a spacing option to leave that space?
by JohnMoe
Thu Jan 30, 2020 6:51 pm
Forum: PowerShell Studio
Topic: Multi-line code formatting issue
Replies: 1
Views: 820

Multi-line code formatting issue

Product: PowerShell Studio 2020 (64 Bit) Build: v5.7.172 OS: Windows 10 Pro (64 Bit) Build: v10.0.18362.0 I've got some code that gets the computers from three seperate ActiveDirectory OUs, and joins them together into one array, similar to this: $allComputers = @(Get-ADComputer -Filter { Name -like...
by JohnMoe
Mon Oct 21, 2019 4:14 pm
Forum: PowerShell Studio
Topic: Incorrect cert used for signing script
Replies: 8
Views: 3144

Re: Incorrect cert used for signing script

Hi Brittney,

PowerShell Studio does indeed sign with the correct cert now. Thanks for your assistance. :-)

Cheers,

John Moe
by JohnMoe
Mon Oct 21, 2019 3:25 pm
Forum: PowerShell Studio
Topic: Incorrect cert used for signing script
Replies: 8
Views: 3144

Re: Incorrect cert used for signing script

Hi Brittney,

Thanks for letting me know, I'll download it now and let you know how I go. :-)

Cheers,

John Moe
by JohnMoe
Wed Sep 25, 2019 3:05 pm
Forum: PowerShell Studio
Topic: Incorrect cert used for signing script
Replies: 8
Views: 3144

Re: Incorrect cert used for signing script

Hi brittneyr, Thanks for the update and the info. I had a look at my certs, given your info about having the same CN, but unfortunately, I can't change either certificate that has that CN; one is from a vendor to communicate with them, and the other is already pushed out to every system in our domai...
by JohnMoe
Tue Sep 24, 2019 4:31 pm
Forum: PowerShell Studio
Topic: Incorrect cert used for signing script
Replies: 8
Views: 3144

Re: Incorrect cert used for signing script

Hi Alexander, Sorry, I'm not sure what you mean? I have a .ps1 file, and I sign it, which adds the signature as text to the bottom of the same .ps1 file? There's no other files involved? Unless this is a product config file, in which case, where do I find that? Hi brittneyr, Thanks for that, I look ...
by JohnMoe
Mon Sep 23, 2019 6:11 pm
Forum: PowerShell Studio
Topic: Incorrect cert used for signing script
Replies: 8
Views: 3144

Incorrect cert used for signing script

Product, version and build: SAPIEN PowerShell Studio 2019 Version 5.6.167 32 or 64 bit version of product: 64-bit Operating system: Windows 10 1903 build 18362.295 32 or 64 bit OS: 64-bit I've selected my code signing certificate in the Options dialog, but when I click the "Sign Script" button and c...
by JohnMoe
Tue Jul 02, 2019 5:40 pm
Forum: PowerShell Studio
Topic: Code colouring not working properly after here-string in Invoke-Command
Replies: 2
Views: 1781

Re: Code colouring not working properly after here-string in Invoke-Command

....aaaaand in typical fashion, once I posted this and went back to my code, as soon as I started typing to finish the line after the here-string, the colouring immediately started working again. So not sure if that initial behaviour is a bug, or just that I hadn't finished the cmdlet? I can't seem ...
by JohnMoe
Tue Jul 02, 2019 5:33 pm
Forum: PowerShell Studio
Topic: Code colouring not working properly after here-string in Invoke-Command
Replies: 2
Views: 1781

Code colouring not working properly after here-string in Invoke-Command

Product, version and build: SAPIEN PowerShell Studio 2019 Version 5.6.165 32 or 64 bit version of product: 64-bit Operating system: Windows 10 Pro 1903 32 or 64 bit OS: 64-bit I'm modifying some code to have a SQL query within the Invoke-Command block, and once I've done that, colouring of code afte...